home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-mail / mailbase-1 / mailbase-1.ebuild < prev    next >
Text File  |  2006-01-20  |  2KB  |  60 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-mail/mailbase/mailbase-1.ebuild,v 1.13 2005/10/09 06:40:48 vapier Exp $
  4.  
  5. DESCRIPTION="MTA layout package"
  6. SRC_URI=""
  7. HOMEPAGE="http://www.gentoo.org/"
  8.  
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
  12. IUSE="pam"
  13.  
  14. RDEPEND="pam? ( virtual/pam )"
  15.  
  16. S=${WORKDIR}
  17.  
  18. src_install() {
  19.     dodir /etc/mail
  20.     insinto /etc/mail
  21.     doins ${FILESDIR}/aliases
  22.     insinto /etc/
  23.     doins ${FILESDIR}/mailcap
  24.  
  25.     keepdir /var/spool/mail
  26.     fowners root:mail /var/spool/mail
  27.     fperms 0775 /var/spool/mail
  28.     dosym /var/spool/mail /var/mail
  29.  
  30.     if use pam;
  31.     then
  32.         insinto /etc/pam.d/
  33.  
  34.         # pop file and its symlinks
  35.         newins ${FILESDIR}/common-pamd-include pop
  36.         dosym /etc/pam.d/pop /etc/pam.d/pop3
  37.         dosym /etc/pam.d/pop /etc/pam.d/pop3s
  38.         dosym /etc/pam.d/pop /etc/pam.d/pops
  39.  
  40.         # imap file and its symlinks
  41.         newins ${FILESDIR}/common-pamd-include imap
  42.         dosym /etc/pam.d/imap /etc/pam.d/imap4
  43.         dosym /etc/pam.d/imap /etc/pam.d/imap4s
  44.         dosym /etc/pam.d/imap /etc/pam.d/imaps
  45.     fi
  46. }
  47.  
  48. pkg_postinst() {
  49.     if [ "$(stat -c%a ${ROOT}/var/spool/mail/)" != "775" ] ; then
  50.         echo
  51.         ewarn
  52.         ewarn "Your ${ROOT}/var/spool/mail/ directory permissions differ from"
  53.         ewarn "  those which mailbase set when you first installed it (0775)."
  54.         ewarn "  If you did not change them on purpose, consider running:"
  55.         ewarn
  56.         echo -e "\tchmod 0775 ${ROOT}/var/spool/mail/"
  57.         echo
  58.     fi
  59. }
  60.